The letter of intent follows Cohere's purchases of Reliant AI and Aleph Alpha. AISLE, founded in 2025 by former Avast chief Ondrej Vlcek, found 18 of the 24 flaws in curl's latest release.
Next.js 16.4.1 fixes two critical flaws that need no login to exploit
EditorialBy TrustList Editorial
One flaw sits in image optimisation of SVG files and reaches back to Next.js 10; the other hits the use cache directive in 16.x and has no workaround. A third advisory fixes a Server Actions denial of service.
About Next.js 16.4.1 fixes two critical flaws that need no login to exploit
Next.js 16.4.1 fixes two critical flaws that need no login to exploit
14 October 2026: Vercel has released Next.js 16.4.1 and 15.5.28 to fix two critical remote code execution flaws that an attacker can trigger without signing in. One, CVE-2026-96889, sits in the Image Optimization API and affects every release from Next.js 10.0.0; the other is in functions marked with the use cache directive and affects the whole 16.x line up to 16.4.0, with no workaround. Vercel published both advisories on GitHub on the afternoon of 14 October, together with a high-severity denial-of-service fix, and tells users to upgrade at once.
Not yet independently verified. Vercel gives no CVSS scores and no CVE number for the use cache flaw, and reports no exploitation in the advisories. We will add both when Vercel publishes them. We will update this when it can be confirmed, and remove this note.
How the image flaw is reached
The Image Optimization API is the endpoint behind the next/image component, which resizes and converts images on the server. Vercel says a memory flaw in an upstream image library it relies on can lead to code execution when the API processes SVG files and the application runs on a Linux distribution built on glibc, which covers most standard Debian and Ubuntu container images.
The vulnerable ranges are 10.0.0 to 15.5.27, fixed in 15.5.28, and every 16.x release after 16.0.0 up to 16.4.0, fixed in 16.4.1. Vercel names a workaround for teams that cannot move Next.js straight away: make sure the sharp package that Next.js uses is at version 0.35.5 or later. A fresh install pulls a fixed sharp automatically, and upgrading Next.js makes the package manager do the same.
The use cache flaw has no workaround
The second advisory, GHSA-673q-mjm6-r5xr, concerns applications on the App Router with Cache Components, where a function marked use cache returns several typed arrays. Vercel rates it critical, lists 16.0.0 to 16.4.0 as affected and 16.4.1 as fixed, and states that there is no known workaround. It asks teams to upgrade even if they believe none of their functions match, which is the safer reading for anyone unsure what a dependency does inside a cached function.
The 15.x line is not listed as affected by this one, because the use cache directive arrived with 16.
A denial-of-service fix in the same release
The third advisory, GHSA-p3m5-59mp-jv5r, is a high-severity denial of service in the App Router through Server Actions. It reaches further back, to 13.0.0, and is fixed in the same two releases. It is the fourth batch of Next.js security fixes in under a month: on 30 September Vercel published a server-side request forgery flaw in image optimisation and several cache leakage issues fixed in the 16.3 line.
What a lockfile check should show
For a team running Next.js on its own servers, the check is two lines in the lockfile: next at 16.4.1 or 15.5.28, and sharp at 0.35.5 or later. Applications on releases older than 15.5 have no patched version in their line and need a larger upgrade. Vercel's advisories do not say whether sites hosted on its own platform needed any action, and neither reports exploitation so far.
We list Vercel and its hosting product; our web hosting software category is small, while our web hosting company category lists 200 firms, many of which run Next.js sites for clients.
Update, 22 October 2026: Vercel's GitHub security advisories for both flaws, published on 14 October, score each at 9.5 under CVSS 4.0. The use cache flaw still carries no CVE number.
Related on TrustList:
- Next.js flaw in next/og ImageResponse allows remote code execution: upgrade to 16.3.6
- Node.js fixes a Brotli remote code flaw and two TLS hostname bypasses
- Deno Deploy to shut in six months as Deno team joins Cloudflare
Sources
- Vercel, GitHub security advisory GHSA-2464-fhr4-w9xw (CVE-2026-96889): Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used, 14 October 2026
- Vercel, GitHub security advisory GHSA-673q-mjm6-r5xr: Unauthenticated Remote Code Execution in use cache functions returning typed arrays, 14 October 2026
- Vercel, GitHub security advisory GHSA-p3m5-59mp-jv5r: Denial of Service in App Router using Server Actions, 14 October 2026
- The Hacker News: Next.js ships out-of-band patch for two critical flaws, 15 October 2026
- Vercel on GitHub: security advisory GHSA-2464-fhr4-w9xw (CVE-2026-96889) - 14 October 2026
Categories & features
- United States
- California
- San Francisco
- Cybersecurity
- Application Security
- Vulnerability Management
- Patch Management
- JavaScript
- React
- Web Development
TrustList Weekly
The week in software and IT, in one email
The news that matters to buyers, new rankings and our own research. Every Thursday, free, and easy to leave.
You may be interested in
Vercel’s advisory of 30 September 2026 says the Node.js ImageResponse in next/og, in Next.js 16.2.0 up to 16.3.6, can allow remote code execution when attacker-controlled values reach SVG content. Upgrade to 16.3.6.
Releases 26.12.1, 24.22.1 and 22.23.4 close ten CVEs, four rated High, and also drop trust in the compromised eMudhra intermediates through the bundled CA store.
Neither bulletin reports exploitation, but ColdFusion servers have been attacked soon after past patch days; AEM 6.5 customers must apply named hotfixes on top of their service pack.
PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35 close CVE-2026-109618 and CVE-2026-109619. Every PHP install serving web requests is at risk, mod_php most of all, and PHP 8.1 and older get no official fix.
SA-CORE-2026-014 scores 19 out of 25. Sites on 11.2 or 10.5 and older have no patch; uninstalling the Field UI module blocks the flaw until an upgrade is possible.
CVE-2026-111497 is rated 9.2 by Google and hits every Brotli release from 1.0.3 to 1.2.0. Envoy, the PyPI packages and Debian have shipped fixes; Ubuntu still ranks it medium.
The alias and rewrite overflow affects every release since 0.1.29. The fix release also moves HTTP/2 to RFC 9218 prioritisation and adds MaxMind DB support to the GeoIP modules.
More on TrustList
Everything here links back to the same verified catalogue. Pick your next stop.
- More United StatesThe ranking for this subject
- CompaniesAgencies, consultancies and IT service providers, ranked by verified reviews.
- ProductsSoftware and SaaS with pricing, features, integrations and alternatives.
- AwardsAnnual recognition decided by verified reviews and an independent jury.
- LaunchesNew products and releases, voted up by the community every day.
- AI ModelsBenchmark scores and community ratings for every major model.
- RequestsBuyers describe what they need; vendors respond directly.
- PeopleReviewers, authors and makers with public profiles.
- ComparePut up to four listings side by side before you shortlist.