They chain with the October zero-day CVE-2026-104935. Federal agencies must act on one by 2 November, and Canada's Cyber Centre now lists 25.1.3.0 among the affected builds.
CISA lists old Strapi, ONLYOFFICE and Struts flaws as exploited
EditorialBy TrustList Editorial
All five flaws were fixed between 2015 and 2023, and the newest is a Strapi admin-panel leak fixed in 4.8.0. Federal agencies have until 11 October to deal with them.
- United States
- Cybersecurity
- Vulnerability Management
About CISA lists old Strapi, ONLYOFFICE and Struts flaws as exploited
CISA lists old Strapi, ONLYOFFICE and Struts flaws as exploited
8 October 2026: The US Cybersecurity and Infrastructure Security Agency has added five vulnerabilities to its Known Exploited Vulnerabilities catalog, all of them patched years ago: a Strapi admin-panel data leak, a path traversal in ONLYOFFICE Docs, command injection in Apache Struts, a denial-of-service bug in ISC BIND and a file read and write flaw in ProFTPD. Federal civilian agencies must deal with all five by 11 October under directive BOD 26-04, a three-day window, and CISA says to stop using a product where no mitigation is available.
Not yet independently verified. CISA does not say who is exploiting these flaws or against which targets, and none of the five vendors has published a new statement. The fixed versions below come from each vendor's original advisory or the NVD record. We will update this when it can be confirmed, and remove this note.
The listing means CISA has evidence of exploitation now, not when the bugs were found. Old flaws keep working where software was installed once and never upgraded, which is common for self-hosted content systems, document servers and FTP boxes.
The five, with the version that fixed each:
- Strapi, CVE-2023-22894 (CVSS 4.9): an attacker with admin-panel access can filter users on private fields and infer password hashes and reset tokens. Fixed in Strapi 4.8.0. CISA notes it can be chained with CVE-2023-22621, a template injection fixed in 4.5.6, to run code.
- ONLYOFFICE Docs, CVE-2021-3199 (CVSS 9.8): path traversal in image upload when JWT is used, leading to code execution. Fixed in Document Server 5.6.3.
- Apache Struts, CVE-2016-3081 (CVSS 8.1): code execution through the method: prefix when Dynamic Method Invocation is on. Affects 2.3.19 to 2.3.28 in three ranges; Apache's bulletin S2-032 gives the fixes.
- ISC BIND, CVE-2015-5477: a crafted TKEY query stops named. Fixed in 9.9.7-P2 and 9.10.2-P3.
- ProFTPD, CVE-2015-3306 (CVSS 10 under the older scoring): the mod_copy module lets an unauthenticated user copy files anywhere the server can write. It affects 1.3.5.
Strapi's own advisory is direct about the line: anything from 3.2.1 up to but not including 4.8.0 is affected, and Strapi v3 receives no security updates at all. CISA flags the Strapi entry as possibly end of life, so a v3 install has no patch to apply and needs a migration.
Our headless CMS category lists seven platforms, Strapi among them, and ONLYOFFICE is in our productivity software listings. CISA marks three of the five, Struts, ONLYOFFICE and ProFTPD, for the forensic triage requirements it published alongside BOD 26-04.
Sources
- CISA: Known Exploited Vulnerabilities catalog (JSON feed, entries added 8 October 2026), 8 October 2026
- Strapi: Security disclosure of vulnerabilities (CVE-2023-22894 and CVE-2023-22621), 17 April 2023
- NVD: CVE-2021-3199 (ONLYOFFICE Document Server before 5.6.3), 26 January 2021
- NVD: CVE-2016-3081 (Apache Struts, Dynamic Method Invocation), 26 April 2016
- NVD: CVE-2015-5477 (ISC BIND TKEY queries), 29 July 2015
- NVD: CVE-2015-3306 (ProFTPD mod_copy), 18 May 2015
Categories & features
- United States
- Cybersecurity
- Vulnerability Management
TrustList Weekly
The week in software and IT, in one email
The news that matters to buyers, new rankings and our own research. Every Thursday, free, and easy to leave.
You may be interested in
The GitLab regex flaw lets an unauthenticated user run code through a CI/CD configuration; the Cisco flaw reloads ASA and FTD firewalls. Both entered the exploited list on 29 October with a three-day deadline.
DSA-2026-416 now covers unauthenticated root command execution, a hard-coded key and rogue admin creation in DD OS, plus three Management Center flaws that reach other managed systems. Fixes ship in 8.9.0.0 and three LTS lines.
Founded by Normalyze co-founder Amer Deeba and former AppDynamics engineering head Ed Rowe, Northstar maps assets, identities and flaws in one graph and exposes it to outside agents over MCP.
CVE-2026-111497 is rated 9.2 by Google and hits every Brotli release from 1.0.3 to 1.2.0. Envoy, the PyPI packages and Debian have shipped fixes; Ubuntu still ranks it medium.
Palo Alto lists every supported PAN-OS line and Panorama as affected by CVE-2026-109618 and CVE-2026-109619 through the management interface. Threat Prevention signatures and access limits are the stopgaps.
Enterprise 10.4.4, 10.2.8, 10.0.11 and 9.4.16 and SOAR 8.7.0 close internally found flaws, an unauthenticated crash of Splunk Web and a sidecar password any low-privileged user could derive.
CVE-2026-91403 in JSSE can be exploited over the network with no login. Every listed build is affected, including 25.0.5 and 21.0.13, so Java estates need to patch again.
More on TrustList
Everything here links back to the same verified catalogue. Pick your next stop.
- More United StatesThe ranking for this subject
- CompaniesAgencies, consultancies and IT service providers, ranked by verified reviews.
- ProductsSoftware and SaaS with pricing, features, integrations and alternatives.
- AwardsAnnual recognition decided by verified reviews and an independent jury.
- LaunchesNew products and releases, voted up by the community every day.
- AI ModelsBenchmark scores and community ratings for every major model.
- RequestsBuyers describe what they need; vendors respond directly.
- PeopleReviewers, authors and makers with public profiles.
- ComparePut up to four listings side by side before you shortlist.