Two flaws rated Important hit all three supported lines, a third affects only Tomcat 11, and the fixed releases have been out since 12 October.
Apache fixes four Struts flaws, one of them OGNL code execution
EditorialBy TrustList Editorial
Italy's national cyber agency rates three of the four as high severity and tells users to update; Apache itself rates the code-execution bug only Moderate and limits it to one mapper.
About Apache fixes four Struts flaws, one of them OGNL code execution
Apache fixes four Struts flaws, one of them OGNL code execution
5 October 2026: The Apache Struts project has published four security advisories, CVE-2026-104711 to CVE-2026-104714, and says users should move to Struts 7.4.0 or, on the 6.x line, 6.12.0. Italy's national cybersecurity agency, ACN, issued an alert on 6 October describing three of them as high severity.
The most serious is CVE-2026-104711 (bulletin S2-075). An OGNL injection in the legacy RESTful action mapper lets a crafted request run code on the server. Apache rates it Moderate because the exposure is narrow. Applications using the default action mapper, the restful2 mapper or the Struts REST plugin are not affected, and Struts 7 is not affected in its default setup, where the OGNL allowlist is switched on. Affected releases run from 2.0.0 to 6.11.0, plus 7.0.0 to 7.3.0 when the allowlist is disabled.
CVE-2026-104712 (S2-076) is a denial of service. If a request parameter is bound to a java.math.BigDecimal property and rendered through the Struts tag library, the response can be many times larger than the request. Apache says a remote attacker needs no login and little bandwidth to exhaust CPU and outbound capacity. Applications that never render such a property are not affected, and neither are the JSON and REST plugins.
CVE-2026-104713 (S2-077) is a second denial of service. The REST plugin reads a request body into memory without a limit. The fixed releases cap it at 2 MB by default, adjustable with the struts.rest.content.maxLength constant. For anyone who cannot upgrade, Apache has no configuration fix inside Struts and suggests enforcing a maximum body size in the reverse proxy or servlet container. The fourth advisory, CVE-2026-104714, concerns a shared message formatter that exposes date and time values across concurrent requests.
Apache's own bulletin for that fourth flaw, S2-078, rates it Moderate and lists its impact as disclosure of data and denial of service. It concerns applications whose localized messages format a date or time argument, and the fix is the same upgrade to 7.4.0, or 6.12.0 on the 6.x line. None of Apache's four bulletins reports exploitation.
Struts 2.3.x and 2.5.x are end of life, and Apache's bulletins list them as affected without a fix. Teams on those lines have to move to 6.12.0 or 7.4.0 rather than wait for a patch. Struts 7.4.0 reached general availability on 2 October.
Company profile on TrustList: Apache Software Foundation
Related on TrustList:
- Apache Tomcat fixes a JNDIRealm password bypass and HTTP/2 mix-up
- Apache Camel 4.22.1 users need 4.22.2 for seven more flaws
- OpenJDK October update fixes 46 CVEs; Corretto builds are out
Sources
- Apache Struts: Announcements 2026 (CVE-2026-104711 to 104714, versions 7.4.0 and 6.12.0), 5 October 2026
- Apache Struts: Security Bulletin S2-075, 2 October 2026
- Apache Struts: Security Bulletin S2-077, 2 October 2026
- ACN (CSIRT Italia): Risolte vulnerabilita in Apache Struts, alert AL06/261006, 6 October 2026
- Apache Struts: Security Bulletin S2-078, 2 October 2026
Categories & features
TrustList Weekly
The week in software and IT, in one email
The news that matters to buyers, new rankings and our own research. Every Thursday, free, and easy to leave.
You may be interested in
A week after 38 advisories, Camel published seven more on 22 October, led by a High-rated XXE in camel-saxon. On the 4.22 LTS line only 4.22.2 fixes them; 4.18.5 and 4.23.0 already do.
Oracle scores the Java gap 9.1 and pulls the eMudhra roots from every supported JDK line; Cisco lists Duo upgrades now, Meraki camera firmware on 18 November and IOS XR 26.4.1 on 30 November.
The quarterly advisory covers Java 8 to 27, with a top score of 7.0, and a separate notice adds the 9.1-rated TLS flaw CVE-2026-91403. Amazon Corretto shipped 27.0.1, 25.0.5, 21.0.13, 17.0.21, 11.0.33 and 8u512.
CVE-2026-91403 in JSSE can be exploited over the network with no login. Every listed build is affected, including 25.0.5 and 21.0.13, so Java estates need to patch again.
E-Business Suite alone gets 194 patches, 31 of them exploitable without a login, led by an Application Object Library flaw rated 9.8. Fusion Middleware gets 206, MySQL 98 and Java SE 55.
Most intrusions trace to CVE-2026-73570 on servers with the optional SNMP package. In one case more than 6,000 mailboxes were down for 48 hours, and patched servers were not breached.
Seven are rated high, including an account takeover through OAuth2 auto-linking and fork workflows that receive repository secrets. Every release up to 28.2.0 is affected; there is no backport line.
More on TrustList
Everything here links back to the same verified catalogue. Pick your next stop.
- More ItalyThe ranking for this subject
- CompaniesAgencies, consultancies and IT service providers, ranked by verified reviews.
- ProductsSoftware and SaaS with pricing, features, integrations and alternatives.
- AwardsAnnual recognition decided by verified reviews and an independent jury.
- LaunchesNew products and releases, voted up by the community every day.
- AI ModelsBenchmark scores and community ratings for every major model.
- RequestsBuyers describe what they need; vendors respond directly.
- PeopleReviewers, authors and makers with public profiles.
- ComparePut up to four listings side by side before you shortlist.