PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35 close CVE-2026-109618 and CVE-2026-109619. Every PHP install serving web requests is at risk, mod_php most of all, and PHP 8.1 and older get no official fix.
Apache HTTP Server 2.4.69 fixes 20 vulnerabilities, including memory-safety flaws in mod_http2 and mod_dav: update web servers
EditorialBy TrustList Editorial
Apache released HTTP Server 2.4.69 on 1 October 2026 with fixes for 20 vulnerabilities: five rated moderate by the project, such as a mod_http2 use-after-free and mod_dav overflows, and 15 low. National CERTs rate several higher. Update 2.4.x.
- Cybersecurity
- Vulnerability Management
- Patch Management
- Web Development
About Apache HTTP Server 2.4.69 fixes 20 vulnerabilities, including memory-safety flaws in mod_http2 and mod_dav: update web servers
Apache HTTP Server 2.4.69 fixes 20 vulnerabilities, including memory-safety flaws in mod_http2 and mod_dav: update web servers
2 October 2026: The Apache Software Foundation released Apache HTTP Server 2.4.69 on 1 October 2026. The project's security page lists 20 vulnerabilities fixed in it: 5 rated moderate and 15 low by Apache. Italy's CSIRT and Spain's INCIBE-CERT issued alerts on 2 October; scoring the same flaws by CVSS, they rate several of them critical or high. No exploitation has been reported.
Not yet independently verified. The project and the national CERTs disagree on severity: Apache rates none above moderate, while the CERTs’ CVSS scores put several in the critical and high bands. We give Apache’s ratings and counts. We will update this when it can be confirmed, and remove this note.
The moderate flaws
- CVE-2026-57941: use-after-free or wild write in mod_http2 through shared session re-entrancy.
- CVE-2026-42528: shared-lock overflow in mod_dav.
- CVE-2026-93546: namespace overflow in mod_dav_fs.
- CVE-2026-63292: stack overflow in mod_vhost_alias.
- CVE-2026-59685: out-of-bounds write in
ap_directory_walk()on case-insensitive filesystems.
Among the 15 low-rated flaws are a limited remote code execution for some internal redirects in CGI directories (CVE-2026-42356), response smuggling in mod_proxy_uwsgi, several mod_auth_digest replay and denial-of-service flaws, a session cookie not removed during internal redirects in mod_session, and fixes that re-address three 2024 flaws, including an SSRF with mod_headers.
Who should act
Apache httpd runs a large share of the world's websites, and it is also embedded in appliances, hosting control panels, application servers and vendor products, where it is updated only when the vendor ships a new build. Memory-safety flaws in modules such as mod_http2 and mod_dav are the kind researchers turn into working attacks after a release.
What to do
- Update every Apache 2.4.x server to 2.4.69, starting with internet-facing ones that use HTTP/2 or WebDAV.
- If you cannot update today, disable modules you do not use (mod_dav, mod_dav_fs, mod_vhost_alias, mod_proxy_uwsgi, mod_auth_digest) and review HTTP/2 exposure.
- Linux distributions backport fixes under their own version numbers: check your distribution's advisory rather than the version string.
- Ask appliance and software vendors whose products bundle Apache when they will ship 2.4.69.
Correction, 28 October 2026: an earlier version of this item said Apache's page listed 23 vulnerabilities, 18 of them rated low. The project's security page lists 20 for 2.4.69, five moderate and 15 low, and the national CERTs counted the same 20.
Sources
Categories & features
- Cybersecurity
- Vulnerability Management
- Patch Management
- Web Development
TrustList Weekly
The week in software and IT, in one email
The news that matters to buyers, new rankings and our own research. Every Thursday, free, and easy to leave.
You may be interested in
SA-CORE-2026-014 scores 19 out of 25. Sites on 11.2 or 10.5 and older have no patch; uninstalling the Field UI module blocks the flaw until an upgrade is possible.
The alias and rewrite overflow affects every release since 0.1.29. The fix release also moves HTTP/2 to RFC 9218 prioritisation and adds MaxMind DB support to the GeoIP modules.
One flaw sits in image optimisation of SVG files and reaches back to Next.js 10; the other hits the use cache directive in 16.x and has no workaround. A third advisory fixes a Server Actions denial of service.
Neither bulletin reports exploitation, but ColdFusion servers have been attacked soon after past patch days; AEM 6.5 customers must apply named hotfixes on top of their service pack.
On 25 September 2026 CISA listed two more flaws as exploited: a SharePoint Server code-injection flaw fixed in Microsoft’s August 2026 updates, and a WordPress core file-inclusion flaw fixed in 7.1.2 on 22 September. Confirm both updates are installed.
FoxIO found seven of ten HTTP/3 stacks open to header amplification. quic-go, Cloudflare quiche, lsquic and Wireshark are fixed; Bun, the h3 crate and aioquic are not, and a proof of concept is public.
CVE-2026-114509 lets an attacker with no token log in as an existing user on apps using TokenGuard with MySQL or MariaDB. Upgrade to 13.29.0 or 12.68.0; a proof of concept is public.
More on TrustList
Everything here links back to the same verified catalogue. Pick your next stop.
- More CybersecurityThe ranking for this subject
- CompaniesAgencies, consultancies and IT service providers, ranked by verified reviews.
- ProductsSoftware and SaaS with pricing, features, integrations and alternatives.
- AwardsAnnual recognition decided by verified reviews and an independent jury.
- LaunchesNew products and releases, voted up by the community every day.
- AI ModelsBenchmark scores and community ratings for every major model.
- RequestsBuyers describe what they need; vendors respond directly.
- PeopleReviewers, authors and makers with public profiles.
- ComparePut up to four listings side by side before you shortlist.