An attacker used a compromised GitHub account and leaked credentials for four weeks, copying customer contacts, contract terms, SQL editor text and encrypted API keys. PingCAP says the databases themselves were not reached.
Roundcube webmail flaw fixed in May is now being exploited
EditorialBy TrustList Editorial
Attackers are using CVE-2026-48842, a pre-login SQL injection in Roundcube's virtuser_query plugin, four months after the fix. Anyone running Roundcube, or buying mail from a host that does, should check for 1.6.19 or 1.7.4.
About Roundcube webmail flaw fixed in May is now being exploited
Roundcube webmail flaw fixed in May is now being exploited
24 September 2026: A flaw in Roundcube, the open-source webmail software used by many hosting companies and by organisations that run their own mail, is being exploited. The Canadian Centre for Cyber Security updated its advisory AV26-503 on 21 September 2026 to say that CVE-2026-48842 "is being exploited in the wild". BleepingComputer reported the warning on 24 September and dated it to 22 September; the advisory page itself shows 21 September.
What the flaw does
CVE-2026-48842 is an SQL injection in Roundcube's built-in virtuser_query plugin that works before anyone logs in. An attacker can get past authentication and read data from Roundcube's database without any action by a user. The Shadowserver Foundation tracks about 523,000 Roundcube installations reachable from the internet, according to BleepingComputer, although only those using the affected plugin are exposed.
Roundcube fixed the flaw in versions 1.6.16 and 1.7.1 on 24 May 2026. Three further security releases have followed, and the newest, 1.6.19 and 1.7.4, came out on 6 September. The flaw was not on CISA's exploited list as of its 24 September catalogue.
Who is affected
Any organisation that runs Roundcube below 1.6.16 or 1.7.1 with virtuser_query configured. It also reaches businesses that never installed Roundcube themselves: many web hosts and control panels offer it as their webmail, so the version in use is the host's decision.
What to do
- If you run Roundcube, upgrade to 1.6.19 or 1.7.4 rather than stopping at the minimum fixed version, because the later releases fix further flaws.
- Check whether
virtuser_queryis configured. If you cannot upgrade straight away, disable or remove it. - If your hosting or mail provider offers Roundcube, ask which version it runs and when it was last updated.
- Look for unexpected logins or database reads since late May, and treat any stored mail credentials as at risk if you find them.
Related on TrustList:
- PingCAP breach: TiDB Cloud users told to replace API keys now
- psqlODBC 18.00.0006 fixes two more memory corruption flaws
- DuckDB 1.4 support ends 17 November as 2.0 LTS ships
Sources
- Canadian Centre for Cyber Security: Roundcube security advisory (AV26-503), updated 21 September 2026 - 21 September 2026
- Roundcube news: security updates (read 25 September 2026) - 25 September 2026
- BleepingComputer: Hackers now exploit critical Roundcube flaw in code injection attacks - 24 September 2026
Categories & features
TrustList Weekly
The week in software and IT, in one email
The news that matters to buyers, new rankings and our own research. Every Thursday, free, and easy to leave.
You may be interested in
DuckDB 2.0 is supported until at least October 2027 and 1.5 has been extended to March 2027. Files written by 2.0 cannot be read by any older version, so upgrade order matters.
The project had planned an October release. Between eight and ten features, including SQL/PGQ graph queries, were pulled from the branch during beta and move to PostgreSQL 20.
The worst, CVE-2026-107815 (CVSS 8.5), lets a user of the CONNECT engine crash the server or run code; the fixed releases have been out since 13 August, but the CVE numbers only arrived on 9 October.
The flaws range from NoSQL injection to silent loss of client-side encryption and shared connections across client certificates. Several fixes change driver behaviour, so test before upgrading.
E-Business Suite alone gets 194 patches, 31 of them exploitable without a login, led by an Application Object Library flaw rated 9.8. Fusion Middleware gets 206, MySQL 98 and Java SE 55.
Every release from 08.01.0102 to 18.00.0004 is affected. An application that builds IN lists from user input can be crashed, or left running on a corrupted heap.
A user who knows one SCRAM password can log in as any other SCRAM user, superusers included, on PgBouncer 1.17.0 to 1.26.0. Two further flaws let unauthenticated clients hang the pooler under specific settings.
More on TrustList
Everything here links back to the same verified catalogue. Pick your next stop.
- More CybersecurityThe ranking for this subject
- CompaniesAgencies, consultancies and IT service providers, ranked by verified reviews.
- ProductsSoftware and SaaS with pricing, features, integrations and alternatives.
- AwardsAnnual recognition decided by verified reviews and an independent jury.
- LaunchesNew products and releases, voted up by the community every day.
- AI ModelsBenchmark scores and community ratings for every major model.
- RequestsBuyers describe what they need; vendors respond directly.
- PeopleReviewers, authors and makers with public profiles.
- ComparePut up to four listings side by side before you shortlist.